Neue Kamerahalterung, neue Getriebemotoren und Motoransteuerung

Neun Monate ist es her, dass sich hier was tat. Na ja, schwanger ist der Roboter zwar noch nicht, aber „neu geboren“ doch wohl. Aber der Reihe nach. Da sich die Gelegenheit ergab, wurde heute erst mal das Webdesign etwas aufgefrischt. Eine neue Rubrik ist dabei auch dazu gekommen: Screenshots. Hier ist sehr schön, der Werdegang des Programmes mit all seinen Irrungen und Wirrungen zu erkennen. Die augenfälligste Neuerung ist sicher leicht zu erkennen – die Entwicklung läuft mittlerweile vollständig unter Linux (mit KDevelop (und natürlich weiterhin mit dem Qt-Framework (Open Source Version)).

Für die Interessierten: Einem weiteren Einsatz unter Windows steht aber – dank Qt – weiterhin nichts im Weg. Mein besonderer Dank geht hier an Oliver Bock, ohne den dieser Schritt nicht möglich gewesen wäre. Er hat den Cypress CY7C63-Linux-Treiber vom 2.4er auf den aktuellen 2.6er Linux-Kernel portiert. Ohnehin hat er mich bei diversen Programmier- und Linux-Fragen in diesem Projekt hier großartig unterstützt.

Was geschah mit der Hardware? Nun, die Kamera hat eine etwas stabilere Halterung bekommen

und einen eigenen Anschluss an den Akku:

Auch der Video-Ausgang (s/w) ist schon mal zum Anschluss an das Laptop vorbereitet worden:

Bei einem Vergleich der zwar sehr kräftigen Schrittmotoren mit Getriebenmotoren aus dem Modellbaubereich sollte sich herausstellen, dass letzere bei ausreichend Kraft haben (bei 5000 U/Min bei 12V, 148:1 Untersetzung) und dabei der Roboter nun ungefähr 1,2 km/h schafft!

Siehe dazu auch ein aktuelles Video . Dieses war der erste Versuch mit den schnellen, neuen Motoren, darum kommt die „Kameraführung“ nicht wirklich hinterher. ;-) Und ein paar Sensoren mehr, braucht er wohl auch noch…

Somit sind also nun neue Getriebemotoren montiert,

die natürlich einer komplett neuen und anderen Ansteuerung bedurften. Also wurde die alte Platine demontiert,

und da es sich anbot, die neue Platine an eine sicherere Stelle als bisher zu montieren, wurde gleich alles an Kabeln entfernt und neu gemacht:

Und so sieht das ganze jetzt aus:

Die Platine zur Motoransteuerung ist übrigens ein Fertigmodul von robotikhardware.de , gemäß Roboternetz-Definition . Die USB-Platine ist von ak-modulbus . Hier sind die Sensoren mit den A/D-Wandlern jetzt modular steckbar gemacht worden. Die alte Platine entfiel damit komplett:

Wie an den Screenshots zu sehen ist, funktioniert das Ansteuern und Auslesen der CMUCAM nun auch einwandfrei. Die Auswertung der Bilder/Daten steht allerdings noch auf einem anderen Blatt…

[239 Aufrufe]